Browser requirements

Browsers

To ensure that you have the best internet banking experience and for your security, make sure you are using the latest supported browsers listed below.

  • Download the latest version of Internet Explorer.  Internet Explorer 11 is currently not supported.
  • Download the latest version of Firefox.
  • Download the latest version of Safari.
  • Download the latest version of Google Chrome.

Note: we do not support Beta or test versions of browsers.

When you download the supported required browser version, you acknowledge that these are third party sites and we cannot take any responsibility for the consequences of your downloading these browsers.

Standards

For users that are comfortable with technology, the particular specifications that we support are XHTML 1.0 Transitional, CSS 1.0 and 2.0, DOM Level 1 and 2, and ECMA Script (JavaScript). The site will work using all the browsers that correctly implement these specifications.

 

Encryption

To access our services, your browser must also support 128-bit Secure Sockets Layer (SSL) encryption. All the browsers we support meet this requirement. If yours doesn't, please download the appropriate encryption support from your browser's supplier.

 

Cookies

To use our online banking services, make sure you enable your browser to accept cookies. Detailed information on our use of cookies is available in our privacy statement. For more information on enabling and disabling cookies, refer to your browser's Help section or documentation.

 

JavaScript

To use our online banking services, change your browser and/or device settings to enable JavaScript. For more information on enabling JavaScript, refer to your browser's Help section or documentation.

 

Hardware

We have no minimum hardware requirements. Keep in mind that certain minimum requirements may be specified by the browser you are using.

 

 

Quick Login